^

Themabewertung:
  • 82 Bewertung(en) - 2.39 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Aufruf von Lichtszenen für Ausgang 3+4
#1
Moin Moin,
ich habe (mal wieder) ein (altes) Problem beim Aufruf von Lichtszenen. Hintergrund: ich möchte Hue-Leuchten über einen externen Controller(Visu) per Status vom LCN schalten und möchte (auch um etwas Resourcen zu sparen) auch die virtuellen Ausgänge dafür mit nutzen (dann wären sie auch gleich dem Raum zugeordnet).

Wenn ich aber eine Lichtszene für Ausgang 1 aufrufe wird auch die für Ausgang 3 eingetragene Lichtszene mit ausgelöst, bei Ausgang 2 reagiert auch Ausgang 4. Das geht so nicht = durchgefallen.
Natürlich kann ich das "umschiffen", wenn ich einfach noch zusätzliche "RAM-Module" (SHS/UPS) einbaue und dort nur Ausgang 1+2 nutze. Aber dafür ist leider im Verteiler auch kein Platz mehr ...

Sind hier meine Module mit FW19... noch zu alt oder können die aktuellen Module das auch (immer) noch nicht?

Grüße, Uwe
Zitieren
#2
Moin Uwe,
ich nutze zwei SHS FW190B11, wo ich die Ausgänge 1 bis 4 (und Relais) per Lichtszenen abrufe und damit HL4 (und Relais per EGR) korrekt ansteuere.

Willst du nach dem Aufruf der Lichtszenen die D1...D4 Statussignale nutzen? Dein Setup habe ich noch nicht recht durchschaut. Stimmen die Ausgänge 1 bis 4 nach Lichtszenenaufruf im Monitor der Pro, oder hast du nur auf deine Visu geschaut?

VG Thomas
___________________________________________________________
LCN seit 2001
Zitieren
#3
Moin Thomas,
ich nutze den Status des Ausgangs auch zur Helligkeitsregelung - in IP-Symcon kann ich das %-genau umsetzen.
Das funktioniert übrigens auch für Lautstärkeregelungen von Sonos oder Alexa - wenn man kurze Latenzzeiten verschmerzen kann.
Bei Hue-Leuchten kommt schon beim funken eine Latenz, da fällt das dann so gut wie gar nicht auf.
Es wird (so ist die Verdrahtung des Elektrikers) meistens die Leuchte bzw. der Controller vom LCN geschaltet, ich nutze also tw. auch noch Statuskommandos vom Ausgang.

Schau dir mal den den FLS von Dresden-Elektronik näher an: der hat 2 Leuchten, eine RGB und eine W.
Ich kann die wunderbar und einzeln über die Ausgänge steuern - nur mit einer LIchtszene darf ich (meist die W) nicht bedienen. Das LCN-Modul und damit auch der Controller schaltet bei einer Ansteuerung des RGB (auf A1) auch das W auf A3 mit an. In der Lichtszene ist auch für A3 etwas eingetragen, mein Kommando geht aber nur an A1.
Die Statuskommandos/meldungen bzw. deren Auswirkungen sehe ich in der Visu und natürlich auch im Bus-Monitor der Pro (die Visu folgt da nur dem Status).

Grüße, Uwe
Zitieren
#4
Wie gesagt, bei meinen FW 190B11 SHS kann ich auch Lichtszenen korrekt aufrufen, bei Szene 7 bleibt A3 aus:

   

Ich würde zur low level Fehlersuche raten.

VG Thomas
___________________________________________________________
LCN seit 2001
Zitieren
#5
Das wäre ja bei dem Eintrag auch richtig, Thomas.
Schalte doch mal A3 ein und rufe dann die Lichtszene 7 nur für Ausgang 1 auf ...

Grüße, Uwe
Zitieren
#6
Hallo Uwe, verstanden, getestet und bestätigt: Bug.

A1 bis A4 aus, A3 ein, Lichtszene 7 (Reg0) nur für A1 aufgerufen:
   
Es wird A1 und A4 eingeschaltet, obwohl A4 nicht angesprochen wurde.

A1 bis A4 aus, A3 bleibt aus, Lichtszene 7 (Reg0) nur für A1 aufgerufen:
   
Es wird nur A1 eingeschaltet.

Der eingeschaltete A3 bewirkt dass A4 mit eingeschaltet wird, obwohl A4 nicht angesprochen wurde. Vermutlich ein Fehler in der A3+A4 Logik für die Lichtszenen. (Wer braucht schon updatefähige Module?)

Wird
   
für A1, A2, A3+4 aufgerufen, wird alles korrekt ausgeführt, egal ob A3 ein oder aus war.


A1 bis A4 aus, A1 ein, Lichtszene 7 (Reg1) für A1, A2, A3+4 aufgerufen:
   
Es wird nur A1 eingeschaltet alles andere aus, wie in der Lichtszene eingestellt.

D.h. ein möglicher Würgaround ist es, Lichtszenen immer für alle Ausgänge aufrufen, zufällig habe ich das so gemacht.

Thomas
___________________________________________________________
LCN seit 2001
Zitieren
#7
(03.10.2018, 10:12)tom-1 schrieb: Der eingeschaltete A3 bewirkt dass A4 mit eingeschaltet wird, obwohl A4 nicht angesprochen wurde. Vermutlich ein Fehler in der A3+A4 Logik für die Lichtszenen. (Wer braucht schon updatefähige Module?)
Die Variante hatte ich noch nicht entdeckt - A4 kann ich aber auch auslösen, wenn ich nur A2 aufrufe.

(03.10.2018, 10:12)tom-1 schrieb: D.h. ein möglicher Würgaround ist es, Lichtszenen immer für alle Ausgänge aufrufen, zufällig habe ich das so gemacht.
"Würgaround" klingt nett - man kann da natürlich schon "tricksen", wir haben ja 100 Lichtszenen. Nur passt das dann leider nicht in die Strukturen meiner restlichen Programmierung, von Logik und Übersichtlichkeit mal ganz abgesehen. Bei einer Anlage mit über 50 Modulen ist der zeitliche Aufwand für solche Änderungen dann aber auch nicht zu verachten.

Grüße, Uwe
Zitieren


Gehe zu: