^

Themabewertung:
  • 88 Bewertung(en) - 2.52 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
PCHK - Openhab2
#1
Hallo liebe Nutzer,

ich habe vor kurzem bereits einen allgemeinen Beitrag bezüglich Software und Hardware Komponenten hier verfasst. Mein großes Ziel ist es, dass ich meine LCN Anlage über Openhab2 und Alexa steuern kann. Bis dahin ist es leider noch ein weiter Weg :-) Aber nachdem ich alle Hardware und Software habe, habe ich die letzten 2 Nächte damit verbracht alles einzurichten. So viel habe ich bisher geschafft:

- Raspberyy mit Raspian zum Laufen bekommen
- Openhab2 auf dem Raspian installiert
- Eine VNC Verbindung zu meinem Mac hergestellt
- Das PKU Modul wurde verbaut (nicht von mir :-)
- Das Raspberry hängt nun am PKU

Nun habe ich versucht den PCHK zum Laufen zu bringen und habe (versucht) mich an der Installationshilfe von Herrn May und Jüttner zu halten:

- Vom Raspberry die Software runter geladen und im Pfad /home/pi/ entpackt
- Installiert
- Daemon gestartet
- Daemon gestoppt
- Daemon restart
- COM-Schnittstelle "erfragt"

Nun wollte ich die xml Datei öffnen (über den Browser) und bekomme schon folgende Fehlermeldung:


This page contains the following errors: error on line 13 at column 65: EntityRef: expecting ';' Below is a rendering of the page up to the first error

Wenn ich die xml.Datei über den Editor öffne sieht diese auch anders aus als die Beispiel Datei in der Installationshilfe. Es fehlen die "Tags": "AutoProductKey" und "AutoUpgradeKey". Weiterhin wird auch mein Lizenzen nicht verschlüsselt.

Hier der Aufbau:

<?xml version="1.0" encoding="UTF-8" ?> 
 <LcnPchkConfiguration xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="lcnpchkconfig.xsd">
  <Header>
   <Version major="1" minor="0" /> 
    <Generator>LCN-PCHK 3.2</Generator> 
   </Header>
  <Global>
   <Language>de</Language> 
  </Global>
  <LicenseInformation>
   <Licensee>XXXXXXX</Licensee> 
   <LicenseKeys>
    <LicenseKey xsi:type="AutoKey">XXXXXXXXXXX</LicenseKey> 
   </LicenseKeys>
  </LicenseInformation>
  <LcnRealTimeClockSync xsi:type="SyncAutoDetect" />
  <Communication>
   <LCNPort>ttyUSB0</LCNPort> 
   <HostPort>TCP/IP</HostPort> 
   <TCPPortNum>4114</TCPPortNum> 
   <TCPInactivityTimeout>1800</TCPInactivityTimeout> 
   <User>XXXXXXXXX</User> 
   <HostId>4</HostId> 
   <RemoteConfigurationXmlRpcPort>4220</RemoteConfigurationXmlRpcPort> 
  </Communication>
 </LcnPchkConfiguration>

Ich komme einfach nicht weiter :-(

Ich hoffe ich konnte mich einigermaßen ausdrücken und ihr versteht mein Problem und ich stelle mich nicht zu doof an und ihr schlagt alle die Hände über dem Kopf zusammen :-)

Vielen Dank und Grüße

Lisa
Zitieren
#2
Hallo zusammen,

Kann mir hier niemand helfen? Ich komme einfach nicht weiter.

Vielen Dank

LG Lisa
Zitieren
#3
Hey Lisa,

die Lizenzen werden erst nach einem erfolgreichem Start des PCHK verschlüsselt.

Ich vermute du hast die aktuelle Version 3.2.2 von unserer Seite geladen? Darin ist eine Readme mit der Installationsanleitung.

Normalerweise reicht es nämlich den PCHK einmal zu starten. Nur wenn du die XML-Datei veränderst muss der Dienst neugestartet werden. Also z.B. wenn du den COM-Port anpasst. Das sollte allerdings überhaupt nicht nötig sein, da der PKU per udev-rule immer auf den Port 0 gemapt wird. Falls du noch weitere USB-Geräte angeschlossen hast, könnte das allerdings zum Problem werden.

Eine weitere Möglichkeit den Fehler zu finden ist überhaupt erstmal zu schauen ob der PCHK-Dienst läuft. Du kannst den Dienst mit dem Kommanden "sudo systemctl status lcnpchk" abfragen. Poste doch mal die Ausgabe von dem Befehl.

Hast du eventuell auch einen Windows-Pc zur Verfügung? Dort könntest du den PCHK-Monitor starten und prüfen ob du eine Verbindung zum PCHK auf dem Pi herstellen kannst. Hier kannst du dann auch den PCHK parametrieren und die Lizenzen eintragen.

Viele Grüße aus der Entwicklung
Mit freundlichen Grüßen von der LCN-Softwareabteilung
Zitieren
#4
Hallo Software-MP,

ich habe jetzt nochmal alles deinstalliert und alles nach der "README" Anleitung durchgefhrt. Dann habe ich die Abfrage von dir eingegeben und bekomme folgende Ausgabe:

● lcnpchk.service - LSB: LCN pchk
Loaded: loaded (/etc/init.d/lcnpchk; generated; vendor preset: enabled)
Active: active (running) since Sat 2017-12-30 21:34:46 CET; 1 weeks 1 days ag
Docs: manConfusedystemd-sysv-generator(8)
CGroup: /system.slice/lcnpchk.service
└─15840 /usr/bin/lcnpchk -f /var/lib/lcnpchk/lcnpchk.xml -d /usr/shar

Dec 30 21:34:46 BenRasp systemd[1]: Starting LSB: LCN pchk...
Dec 30 21:34:46 BenRasp lcnpchk[15833]: Starting LCN pchk: lcnpchk.
Dec 30 21:34:46 BenRasp lcnpchk[15833]: .
Dec 30 21:34:46 BenRasp systemd[1]: Started LSB: LCN pchk.

Ist das so richtig :-)

Vielen Dank fuer die Hilfe!!

Viele Gruesse

Lisa
Zitieren
#5
Hallo Lisa,

ja das sieht gut aus. Der PCHK läuft auf jeden Fall. In der Ausgabe sieht man auch den Pfad aus dem er die Konfigurationsdatei läd: /var/lib/lcnpchk/lcnpchk.xml
In dieser Datei sollte jetzt deine Lizenz auch verschlüsselt sein. Falls dort keine Lizenz eingetragen ist, war etwas bei der Eingabe nicht korrekt... Am besten den Key in einen Editor deiner Wahl kopieren und die Leerzeichen sowie Bindestriche entfernen, ggf. & durch &amp; ersetzen. Danach den Key per copy and paste in das Konsolenfenster bei der Abfrage einfügen. So vermeidest du Tippfehler.

Alternativ ist wie gesagt die Konfiguration über den PCHK-Monitor für Windows möglich. Dort kannst du den Key direkt reinkopieren.

Das install-Skript kopiert alle benötigten Dateien direkt an die richtige Stelle. Hast du den PCHK mit dem Skript uninstall.sh deinstalliert? Laut deiner Ausgabe scheint der PCHK nämlich schon seit dem 30.12. zu laufen...

Viele Grüße
Mit freundlichen Grüßen von der LCN-Softwareabteilung
Zitieren
#6
Hallo Software -MP,

das irritiert mich ein wenig. Wenn ich die xml. Datei öffne ist der Lizenzschlüssel immer noch nicht verschlüsselt.

Da ich "nur" ein Mac zu Hause habe, habe ich mir das Programm Wine runtergelassen und damit den LCN PCHK Monitor gestartet.. Hier sieht eigentlich auch alles in Ordnung aus. Habe ein Screenshot angehängt.

Danke für deine Hilfe

Grüße Lisa

[attachment=651]


Angehängte Dateien Thumbnail(s)
   
Zitieren
#7
Hallo Lisa,

der PCHK läuft auf jeden Fall ordnungsgemäß und hat auch eine Verbindung zum Bus.

Im PCHK-Monitor unter Settings (rechte Seite, mittig) kannst du die Konfiguration ändern und/oder Lizenzen eingeben.

Schau doch mal ob der PCHK deine Lizenz erkannt hat und gibt sie ggf. einfach nochmal im Monitor ein.
Mit freundlichen Grüßen von der LCN-Softwareabteilung
Zitieren
#8
Hallo Software-MP,

super. Habe jetzt nochmal den Key eingegeben und es klappt alles.

Vielen Dank für deine Hilfe!!

Grüsse
Lisa
Zitieren


Gehe zu: