^

Themabewertung:
  • 65 Bewertung(en) - 2.48 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
PCHK auf Linux disconnected sofort
#1
Moin,
da ich gerade meine Server-Landschaft ein wenig auf/umräume, möchte ich gerne mal das PCHK unter Linux probieren (läuft bei mir bisher seit Jahren problemlos auf einem Windows 2012-Server).
Laufen soll das Ganze nun in einer VM auf Ubuntu Server 18.04 LTSR.
Die Installation verlief soweit ok, Verbindungslizenzen (4 Stück) sind eingespielt.
Das starten des Dienstes klappt auch, er horcht auf Port 4114 und 4220.
Als Verbindungs-User und Passwort habe ich die bisher auch auf meinem Windows-Server verwendete Kombination angegeben.

Verbindung mit dem Bus-Monitor von Windows aus klappt auch.

Als Systeme sollen sich ein IPSymcon und 2 Crestron Steuereinheiten anmelden.
Diesen habe ich die neue IP-Adresse mitgeteilt, ansonsten sollte ja alles beim Alten bleiben.
Nach kurzer Zeit meldete der Bus-Monitor auch 3 Verbindungen und ich dachte ich wäre durch.
Bei den drei angebundenen Systemen kommen aber keine Bus-Meldungen an.

Ich habe dann mal versucht mich per Telnet anzumelden. Es folgt der bekannte Anmeldedialog mit Abfrage von Username und Passwort. Es kommt dann auch ein OK, aber dann direkt die Meldung "disconnected".
So sieht´s aus:
Code:
root@UNRAID:~# telnet 192.168.1.6 4114
Trying 192.168.1.6...
Connected to 192.168.1.6.
Escape character is '^]'.
LCN-PCK/IP 1.0
Username:
xxx
Password:
yyy
OK
$io:#LCN:disconnected

Hat da jemand eine Idee wo es hakt?

Merci+Gruß,
der Hocky
Zitieren
#2
Der Meldung nach ist PCHK nicht mit dem LCN-Bus verbunden.

Also mal im PCHK Monitor die Konfiguration des COM-Ports prüfen.

   
Mit freundlichen Grüßen vom LCN-Team

H.Szlopsna
Zitieren
#3
Hm, hab jetzt alles nochmal neu gestartet und nun geht es.
Vielleicht war es gestern Abend schon zu spät und/oder ich habe beim Hin- und Hertesten zwischendurch tatsächlich mal das PKU am falschen Server hängen gehabt.  Shy

Aber nun läuft es - vielen Dank für´s "auf die richtige Fährte bringen".  Smile

VG, Thorsten
Zitieren
#4
Hallo,
ich häng mein aktuelles Problem mal hier dran:
Seit ein paar Tagen können sich meine Systeme nicht mehr mit der PCHK verbinden. Nach dem Login kommt sofort wieder ein "disconnected".

Die log-files sind voll mit der Meldung "Warning: Buffer is full. Packed was dropped.".

Geändert habe ich eigentlich nichts...
Zitieren
#5
Scheint so, als ob da deutlich zu viel Busverkehr herrscht. Mal alle Fremdkopplungen trennen und dann mal schauen, ob PCHK dann wieder stabil läuft.
Mit freundlichen Grüßen vom LCN-Team

H.Szlopsna
Zitieren
#6
Ich hab mal alle Kopplungen getrennt und die PCHK-VM neu gestartet.
Dann war erstmal Ruhe im Log-File.

Dann habe ich mal via telnet eine Verbindung aufgebaut. Nach Login und Passwort kam wieder das bekannte "disconnected" und es rauschen wieder die "Buffer is full"-Warning im Sekundentakt durch.
Zitieren
#7
So, jetzt geht es wieder.
Was habe ich gemacht?
Das vorhandene PKU gegen ein anderes ausgetauscht. Gleichzeitig hatte ich den Speicher für die VM von 1GB auf 2GB hochgesetzt.
So lief es dann. Dann testweise das alte PKU wieder angeschlossen - ging immer noch.
Dann noch den Speicher wieder auf 1GB runtergesetzt. Geht immer noch...
Also läuft es nun in der gleichen Konfig. wie vorher.
Seltsam.
Was mir beim Austausch aufgefallen ist: es leuchteten alle vier grüne LEDs am PKU.
Zitieren


Gehe zu: