^

Themabewertung:
  • 52 Bewertung(en) - 2.88 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Temperaturwertanpassung "alte Module"
#1
Question 
Hallo und guten Abend,

ich bin mittlerweile eine Heizungsregelung zu realisieren und läuft auch alles soweit prima. :-)

Es handelt sich um ein "gewachsenes" System aus dem Erbauungsjahr 2011. Das bedeutet: Unterschiedliche Modulversionen und ergo uinterschiedliche Möglichkeiten zur Anpassung innerhalb des Bus.

LCN Pro und GVS sind auch im Einsatz.

Meine Frage: Ich habe durch die Netzteilabwärme in den UP Dosen völlig "verfälschte" Temperaturwerte der angebundenen Sensoren in den GT6 bzw. GT12 Tastern. Echt unschön.

Bei den neueren Modulen konnte ich unter 4-Variablen alles so rechnen lassen, dass es passt.

Leider habe ich noch ein knappes Dutzend alter Module an denen das leider nicht funktioniert. (14er).

Habe über die Suche einen alten Thread ausgegraben, der dieses Thema wohl schonmal gelöst hatte - jedoch kann ich den Screenshot, der wohl alles erklärt nicht öffnen. Hier war mal die Lösung ...

Habe schon die Werte für TVar über ein anderes Modul hochrechnen lassen(--> Betriebsmeldungen - Kommandos) , jedoch ist das immer nur von kurzer Dauer (ca. 30 sek) - dann wird der Wert wieder zurückgesetzt.

Daher erbitte ich Hilfe zu diesem Thema, damit ich das richtig konfigurieren kann.

Huh Huh Huh

Herzlichen Dank - Stephan
______________________________________________________________

Die Lösung finden Sie hier:
https://forum.lcn.eu/showthread.php?tid=...41#pid7241
Zitieren
#2
Das kann ich nach nachvollziehen, nach über 10Jahren mit LCN. Aber ich habe den einen LCN-TS, den ich habe, aus dem Bereich der Dose abgesetzt.
Vor ~ 10 Jahren habe ich dann meine eigenen I-Port Sensoren gebaut, die einfach kleiner sind, und einfach abgesetzt werden konnten. (Auf Basis DS18x20)
Das läuft auch heute noch, aber ich habe die Entwicklung abgegeben, und mache im Bereich LCN nur noch den Erhalt meiner alt Anlage.

Und das Verrechnen der Modulabwärme ist mist, egal welches System da hinter steckt !
Das habe ich durch, und eine Temperatur wird da gemessen, wo es passt, ohne Einflüsse !
Zitieren
#3
Moin Stephan

Ich poste heut Abend mal ne Kurzanleitung...

Mfg Carsten
Wenn jeder nur an sich denkt, dann ist doch an Jeden gedacht ...   Dance
Discord GLT : https://discord.gg/kEDwxfq
YT-Kanal : Lucky LPA
Zitieren
#4
(27.11.2019, 22:27)Thomas schrieb: Das kann ich nach nachvollziehen, nach über 10Jahren mit LCN. Aber ich habe den einen LCN-TS, den ich habe, aus dem Bereich der Dose abgesetzt.
Vor ~ 10 Jahren habe ich dann meine eigenen I-Port Sensoren gebaut, die einfach kleiner sind, und einfach abgesetzt werden konnten. (Auf Basis DS18x20)
Das läuft auch heute noch, aber ich habe die Entwicklung abgegeben, und mache im Bereich LCN nur noch den Erhalt meiner alt Anlage.

Und das Verrechnen der Modulabwärme ist mist, egal welches System da hinter steckt !
Das habe ich durch, und eine Temperatur wird da gemessen, wo es passt, ohne Einflüsse !

Teilweise hab ich auch Sensoren in den Rahmen der Gira System 55 Rahmen eingebaut. (unten in die Ecke mit kleinen eingefrästen Lüftungsschlitzen) - die sind bis auch ein zehntel deckungsgleich mit meiner "referenzmessung" mit einem PT-1000er.

Aber im Wohnbereich sind nunmal die GT6/TS und GT/12 TS und die sind nunmal nicht richtig kompatibel mit System 55 :-(

Aber es ist ja lösbar und ich brauche es nicht auf einen Zehntel genau. Ich denke meine Anpassung um 2-5°K ist bei Weitem im Linearen Bereich und daher ok. Bin ja nicht im Labor, sondern im Wohnbereich :-)

Dennoch sollte bei realen 20°C auch ca. 20°C im System sein.

VG Stephan

(28.11.2019, 06:57)LuckyLPA schrieb: Moin Stephan

Ich poste heut Abend mal ne Kurzanleitung...

Mfg Carsten


Ein Träumchen :-) - Danke dir !!

Ich warte gespannt ^^

VG Stephan
Zitieren
#5
Moin.

Bin etwas im Stress und hänge deshalb einfach mal 2 alte TD´s von LCN an... Nächste Woche hab ich wieder mehr Zeit um das ggf genauer zu erklären.
@Admins: Hoffe das ist ok, ansonsten einfach wieder löschen...

mfg Carsten


Angehängte Dateien
.pdf   td-differenzwertregelung.pdf (Größe: 744,01 KB / Downloads: 54)
.pdf   tdi-regler.pdf (Größe: 516,98 KB / Downloads: 50)
Wenn jeder nur an sich denkt, dann ist doch an Jeden gedacht ...   Dance
Discord GLT : https://discord.gg/kEDwxfq
YT-Kanal : Lucky LPA
Zitieren
#6
Hi Carsten,

habe mich heute mal den Vormittag beschäftigt mit den Unterlagen, aber ich bekomme es leider nicht hin :-(

Bekomme die wildesten Werte angezeigt, aber nicts was so richtig Sinn ergibt.

Ich glaube ich habe in der Sache noch einen grundlegenden Verständnisfehler.

Ich verstehe noch nicht, wie ich den Wert für die Temperatur (LCN nativ) von einem anderen Modul heraus sinnvoll beeinflussen kann. Soweit ich das verstanden hatte, ist das der einzige Weg, um bei den älteren Modulen den Temperaturwert zu beeinflussen.

Danke für deine Hilfe!

Viele Grüße
Stephan
Zitieren
#7
Moin Stephan,
bei den älteren GT... (Stecksockel, TS im Tragrahmen plazierbar) kann die Anordnung des TS schon entscheidend sein (es gibt ja mehrere Möglichkeiten).
Auch die Nutzung des Corona-Lichts (wenn vorhanden) wird den Sensor übrigens 'anheizen'. Man sollte die dann möglichst nicht schalten - an oder aus und entsprechend anpassen.

Wenn du den Wert im Modul anpassen willst benötigst du mind. beide Regler. In einer sollte der TS seinen Wert ablegen (und möglichst nicht nach Tvar kopieren), im anderen kannst du dann rechnen.
Die letzen 3 Stellen des nativen Wertes ist die Temperatur (immer mit 1 Kommastelle). Wenn du also 1k abziehen willst musst du 10 subtrahieren (1,0°C).
Wenn das Modul einen TS erkennt zeigt es den Wert (und die Rechnung) ggf. in der Pro auch in °C an (das kannst du auch auswählen), dann musst du dort natürlich auch 1,0 eintragen.
Mit Hilfe einer Var die 0 (Null) ist - z.B. Tvar oder auch ein ungenutzer Ausgang - kannst du so auch einen Wert aus einem anderen Modul holen/addieren. Der Wert ist dann i.d.R. nativ und beginnt bei positiven Temperaturen immer mit einer 1xxx (990 wäre -1°C).

Zum aktiven schalten der Heizung nimmst du dann den Regler mit der "korrigierten" Rxvar oder oder du verwendest diese auch in einem Schwellwert.
Die 'alten' TD von Carsten beschreiben die Grundlagen schon sehr gut - damit solltest du entstehende Verständnisprobleme 'grundlegend' erklären können.

Grüße, Uwe

- nur mal am Rande: bei neuen Modulen/GTx sind solche Anpassungen übrigens nicht mehr nötig, da hat die Entwicklung ganze Arbeit geleistet Thumbup
Zitieren
#8
Hi Uwe,

danke für deine Ausführungen! - Ich werde mich damit mal wieder an die Pro setzen und ein wenig probieren. Melde mich dann! - Klingt auf jeden Fall sinnig! - Ist jedoch ein anderer Weg als mit die Hotline "zugerufen" hatte.

Viele Grüße
Stephan
Zitieren
#9
Moin,
damit etwas Licht ins Dunkle kommt. Mit einem Regler vom Regler abziehen, halt ich für nicht sehr praktikabel, nur in der TVar lassen sich feste Werte setzen (außer man kopiert diese).


Das Ganze lässt sich recht einfach lösen, man benötigt dazu nur ein Modul.

Zuerst stellen wir die Variablen, wie folgt ein:
   

Den Regler 2 programmieren wir so:
   
Regler 1 können wir nicht nutzen, da in der R1Var der Temperaturwert liegt, dies würde zu Sprüngen führen.

In den Betriebsmeldungen programmieren wir:
   
Addiere 1030 bedeutet 3°C von der R1Var abziehen. Die 1000 muss addiert werden, da das Modul sonst nicht korrekt rechnen kann und selbst versucht, das richtige zu finden und der Wert springt, um 1000 hin und her.
Die BM nutzen wir, damit nach einem Neustart, die abzuziehende Temperatur automatisch wieder in die TVar geschrieben wird.

Im Status bekommen wir folgende Anzeige:
   
TVar = 1030 (3°C)
R1Var ist der aktuelle falsche Wert
R2Var = R1Var - TVar dieser Wert wird für den Regler benutzt

-------------------------------------------------------------------------------------------------

Benötigt man 2 Regler, stellt man die Variablen vom 1. Sensor auf TVar anstatt R1Var. Als nächstes muss man die TVar in einem anderen Modul auf 1030 setzen und im Regler selbst, die ID vom Operanten ändern.
Mit freundlichen Grüßen vom LCN-Team

S.Brennecke
Zitieren
#10
Einen wunderschönen guten Morgen :-)

Ein herzliches Dankeschön für die Klarstellung und saubere Erklärung - diese funktioniert super. Habe schon alles umgebaut. War ein wenig Arbeit die ganzen Temperaturschreiber, Regler etc. im GVS anzupassen - aber nun passt alles soweit.

Vielen Dank und nachher einen guten Start ins WE!

P.S: Am besten dieses Thema mal sauber "pinnen", damit es bei Bedarf auch mit der guten Anleitung durch andere Suchende wieder aufgefunden werden kann.

:-) VG Stephan
Zitieren


Gehe zu: